When setting up a Raspberry Pi with SqueezePlug, my favorite distribution for setting up a music server I always get the error message “avahi-daemon disabled because there is a unicast .local domain” because I have a lot of Apple equipment configured with Bonjour. To fix it, all you need to do is to edit /etc/default/avahi-daemon and change the line:

AVAHI_DAEMON_DETECT_LOCAL=1

to

AVAHI_DAEMON_DETECT_LOCAL=0

then restart the Avahi-daemon with

sudo service avahi-daemon restart

Problem solved.